XenApp 6.5 Sessions disconnect after opening a new application

So this was a hair pulling event.

Problem:

  • I open one application – APP1
  • I launch another application published from the same server – APP2
  • APP2 goes through the lunching process
  • APP1 disconnects immediately
  • When APP2 launches, APP1 is reconnected
  • I launch APP3, all apps disconnect
  • When APP3 is fully up, APP1 and APP2 reconnect

I can see that all APPS have the same session id, so session sharing IS working.

I read a post that creating the reg key below on the device you are connecting from fixes the issue which I can confirm it helped, however I have 10,000 users to deploy this to, and want to see if Citrix has a fix for it.

In addtion it appears there may be a “private dll” from Cirix in the works.  I placed an entry in this Citrix Forum and I am hoping a Citrix engineer gets back at me.

What I tried:

Fix 1: If you are running 3.1 / 3.2
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Citrix
Name: ReconnectWithNewApplication
Type: Reg_DWORD
Data: 1

Fix 2: (Downgrade your client!)

The Receiver client that is working for me is 13.0.0.6685

The Fix:

Of course this will require for you to apply this on a test server or create a new PVS image.  However, installing the Rollup Pack 1 for XenApp 6.5 fixed the issue.

Hotfix Rollup Pack 1 for Citrix XenApp 6.5 for Microsoft Windows Server 2008 R2
http://support.citrix.com/article/CTX132122

Session sharing fails for sessions launched from Version 5.4 of the Web Interface if:

The Client printer redirection XenApp policy is set to Allowed (default), but the Enable printer mapping option >under Remote Connection > Connection Performance on the Web Interface is cleared, or
the Client printer redirection XenApp policy is set to Prohibited, but the Enable printer mapping option under >Remote Connection > Connection Performance on the Web Interface is checked.

About these ads

About CyberRuiz
Highly motivated with over 12 years experience on Citrix/VMWare/Microsoft/technologies. Exceptional communication skills and team player. CCIA – Citrix Certified Integration Architect. CCEA – Citrix Certified Enterprise Administrator. VCP – VMWare Certified Professional in ESX 2.x, VI3, VI4 MCSE – Microsoft Certified Systems Engineer

One Response to XenApp 6.5 Sessions disconnect after opening a new application

  1. Citrix Admin says:

    Thanks for posting this… I had a bunch of XA 6.5 hot fixes and the issue still remained. I thought it was Citrix Web Interface or some issue with the client. I can confrim this fixes the problem

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

Follow

Get every new post delivered to your Inbox.

Join 53 other followers

%d bloggers like this: